Tablas de p-valor con asteriscos de significancias en Excel

La entrada proporciona un if, que permite colocar los famosos asteriscos de significancia a los p-valor obtenido de alguna rutina econométrica.

Paso 1.

Crear la tabla con los p-valor. En este ejemplo corresponden a p-valor del test  de cointegración de Engle-Granger, aplicado a series de tipos de cambio.

Brasil México Colombia CostaRica Honduras Chile
0.001 0.3402 0.0626 0.6136 0.001 0.1952
0.1151 0.0552 0.1005 0.1016 0.1049 0.009
0.117 0.117 0.0947 0.1141 0.129 0.1185

Paso 2.

Usando como referencia la celda en la cual se encuentra el p-valor que deseamos obtener (cambias b22 por la celda donde se encuentra tu p-valor), colocamos el siguiente if anidado, en la parte de la nueva tabla que le corresponde:

=SI(B22<0.01;B22&"***";SI(Y(B22>0.01;B22<0.05);B22&"**";SI(Y(B22>0.05;B22<0.1);B22&"*";B22)))

Resultado

Brasil Mexico Colombia CostaRica Honduras Chile
0.001*** 0.3402 0.0626** 0.6136 0.001*** 0.1952
0.1151 0.0552* 0.1005 0.1016 0.1049 0.009***
0.117 0.117 0.0947* 0.1141 0.129 0.1185





























Entradas populares de este blog

Valores perdidos (NA) en R: identificación y tratamiento (I)

Ejemplos de tablas en Stata

Métodos y técnicas de Investigación Económica